I cleanly installed etch on an old PC. And NFS didn’t work. Now it looks working but I don’t know why.

I have an old PC given by a friend. And I installed Debian etch 4.0 via network. I installed NFS server with postgresql 7.4 . I wanted the NFS server and not postgresql . But the NFS server didn’t work even with these lines.

# /etc/init.d/nfs-common restart
# /etc/init.d/nfs-kernel-server restart

When I tried to mount, it says:

mount.nfs: mount to NFS server ‘rpcbind’ failed: RPC Error: Program not registered
mount.nfs: internal error


This command has to show lines with “nfd” and ones with “mountd” if NFS works. But no in the fact.

# rpcinfo -p
program vers proto port
100000 2 tcp 111 portmapper
100000 2 udp 111 portmapper
100021 1 udp 2048 nlockmgr
100021 3 udp 2048 nlockmgr
100021 4 udp 2048 nlockmgr
100021 1 tcp 2571 nlockmgr
100021 3 tcp 2571 nlockmgr
100021 4 tcp 2571 nlockmgr
100024 1 udp 2055 status
100024 1 tcp 4804 status

The selection of postgresql doesn’t have other reasons than I don’t use it. But after I commanded

# /etc/init.d/postgresql-7.4 stop
# /etc/init.d/nfs-kernel-server start
Exporting directories for NFS kernel daemon….
Starting NFS kernel daemon: nfsd mountd.
garlic:~# rpcinfo -p
program vers proto port
100000 2 tcp 111 portmapper
100000 2 udp 111 portmapper
100021 1 udp 2048 nlockmgr
100021 3 udp 2048 nlockmgr
100021 4 udp 2048 nlockmgr
100021 1 tcp 2571 nlockmgr
100021 3 tcp 2571 nlockmgr
100021 4 tcp 2571 nlockmgr
100024 1 udp 2055 status
100024 1 tcp 4804 status
100003 2 udp 2049 nfs
100003 3 udp 2049 nfs
100003 4 udp 2049 nfs
100003 2 tcp 2049 nfs
100003 3 tcp 2049 nfs
100003 4 tcp 2049 nfs
100005 1 udp 888 mountd
100005 1 tcp 891 mountd
100005 2 udp 888 mountd
100005 2 tcp 891 mountd
100005 3 udp 888 mountd
100005 3 tcp 891 mountd

the NFS server started to work. And I could start postgresql without stopping the NFS server, too.
But I reinstalled postgresql .

# aptitude remove postgresql
# dpkg –purge postgresql-7.4

It removed also openssl and ssl-cert . So I commanded these two.

aptitude install ssl-cert openssl
aptitude install postgresql

Restarting the PC, the NFS server works.


One thought on “I cleanly installed etch on an old PC. And NFS didn’t work. Now it looks working but I don’t know why.”

Leave a Reply

Your email address will not be published. Required fields are marked *

*